Netzwerktechnik

Netzwerklabor – Teil 3 – Capture mit Wireshark und warum Telnet nicht mehr zeitgemäß ist

Veröffentlicht
capture mit Wireshark

capture mit Wireshark

In diesem Artikel geht es um erste Gehversuche mit Wireshark, einem Freeware Protocol Analyzer fürs Netzwerk. Wie capturen eine Telnet Session vom Server zu einem Cisco Router inclusive der Authentisierung via Tacacs. Das capture File steht auch für alle zum Download bereit um es auf dem eignenen Computer nachzuvollziehen.

Zunächst betrachten wir den Aufbau: links im Bild die Verkabelung, rechts der logische Aufbau durch die Bildung von VLANs im Switch.

 Verkabelung und logischer Aufbau durch VLANs

Der Switch S1 ist ein Cisco Catalyst 2950, auf ihm sind diverse VLANs eingerichtet die lokale Netze abbilden. Die folgenden Ausschnitte aus der Konfiguration zeigen nur den hier relevanten Teil. Es sind die VLANs 401 und 402

S1#
S1#vlan database
S1(vlan)#show
……

  VLAN ISL Id: 401
    Name: admin1
    Media Type: Ethernet
    VLAN 802.10 Id: 100401
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No

  VLAN ISL Id: 402
    Name: admin2
    Media Type: Ethernet
    VLAN 802.10 Id: 100402
    State: Operational
    MTU: 1500
    Backup CRF Mode: Disabled
    Remote SPAN VLAN: No
……
S1(vlan)#exit
S1#wr t
Building configuration…
…..
hostname S1
……….
!
interface FastEthernet0/13
 description *** LAN R7-LAN und Admin-Netze ***
 switchport trunk allowed vlan 307,401-405
 switchport mode trunk
 duplex full
 speed 100
!
…….
!
interface FastEthernet0/23
 description *** Masterblaster eth2 ***
 switchport trunk allowed vlan 401-405
 switchport mode trunk
!
interface FastEthernet0/24
 description *** Masterblaster Mirror Port ETH1 ***
!
…….
!
monitor session 1 source interface Fa0/23
monitor session 1 destination interface Fa0/24
end

S1#

zeige die VLAN Database

VLAN 401

VLAN 402

zeige die laufende Konfiguration

Interface zum Router R7

erlaube VLAN 401 bis 405

Interface zu Masterblaster

erlaube VLAN 401 bis 405

Mirrorport zu Masterblaster eth1

Spiegelport Session 1 Quelle
Spiegelport Session 1 Ausgabeport

Auf dem Cisco Router R7 werden VLANs als Subinterfaces eingerichtet. Bei der nachfolgenden Konfiguration beschränke ich mich auf das Wesentliche, die VLANs und die Konfigurationsteile für Tacacs.
Es ist zu erkennen, dass für Tacacs die Quelladresse des VLAN 401 verwendet wird, der Tacacs Server 192.168.241.100 wird auch über VLAN 401 direkt erreicht.
Der Key für den Tacacs Server heißt tatsächlich so wie er da steht, ist ja eine Laborumgebung und nichts Produktives.

R7#sh running-config

hostname R7

aaa new-model
!
!
aaa group server tacacs+ tacacs1
 server 192.168.241.100
!
aaa authentication banner ^Cc
tacacs authentication required
^C
aaa authentication fail-message ^C authentication failed ^C
aaa authentication login default group tacacs1
aaa authentication enable default group tacacs1
aaa authorization console
aaa authorization exec default group tacacs1 if-authenticated
aaa accounting commands 15 default start-stop group tacacs1
aaa session-id common
!
interface FastEthernet0/1
 description *** LAN R7-LAN und Admin-LAN ***
 no ip address
 speed 100
 full-duplex
!
interface FastEthernet0/1.401
 description *** admin lan 1 ***
 encapsulation dot1Q 401
 ip address 192.168.241.1 255.255.255.0
!
interface FastEthernet0/1.402
 description *** admin lan 2 ***
 encapsulation dot1Q 402
 ip address 192.168.242.1 255.255.255.0
!
ip tacacs source-interface FastEthernet0/1.401
!
tacacs-server key secrettacacskey

R7#

Zu guter Letzt betrachten wir noch „Masterblaster“, das Mädchen für Alles in diesem Lab. Die Schnittstelle eth1 benötigt überhaupt keine Konfiguration, da sie ausschließlich von Wireshark im promiscous mode für das Mitlesen der Daten verwendet wird. eth2 ist die Schnittstelle in das Lab hinein. Hier betrachten wir nur die für diesen Test relevanten VLANs 401 und 402. Die vergebenen IP-Adressen 192.168.241.100/24 und 192.168.242.100/24 liegen im gleichen Adressbereich wie die Adressen auf R7.

ciscolab@masterblaster:~$ ifconfig -a

eth1      Link encap:Ethernet  Hardware Adresse c4:6e:1f:00:a0:c6
          inet6-Adresse: fe80::c66e:1fff:fe00:a0c6/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:10 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:50 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX-Bytes:2675 (2.6 KB)  TX-Bytes:8134 (8.1 KB)

eth2      Link encap:Ethernet  Hardware Adresse 14:cc:20:00:61:15
          inet6-Adresse: fe80::16cc:20ff:fe00:6115/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:109 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:618 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX-Bytes:13531 (13.5 KB)  TX-Bytes:89882 (89.8 KB)

eth2.401  Link encap:Ethernet  Hardware Adresse 14:cc:20:00:61:15
          inet Adresse:192.168.241.100  Bcast:192.168.241.255  Maske:255.255.255.0
          inet6-Adresse: fe80::16cc:20ff:fe00:6115/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:55 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:163 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX-Bytes:3335 (3.3 KB)  TX-Bytes:20138 (20.1 KB)

eth2.402  Link encap:Ethernet  Hardware Adresse 14:cc:20:00:61:15
          inet Adresse:192.168.242.100  Bcast:192.168.242.255  Maske:255.255.255.0
          inet6-Adresse: fe80::16cc:20ff:fe00:6115/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:0 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:103 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX-Bytes:0 (0.0 B)  TX-Bytes:15901 (15.9 KB)

ciscolab@masterblaster:~$

Wer Wireshark noch nicht hat kann es hier herunterladen – das Programm ist Freeware.

Und hier die capture Datei des nachfolgenden Tests zum Download 40kByte.

 

Details folgen…

Kommentar verfassen