Portchannel mit Trunk zwischen ESXI 6.5 und Cisco Catalyst Switch

Veröffentlicht am Veröffentlicht in Netzwerktechnik

Für das Loadbalacing zwischen einem ESXI 6.5 Server und einem Cisco Catalyst 3750G soll ein Portchannel mit 3 Gigabit Ethernet Links etabliert werden.
Einem einzelnen Client steht weiterhin nur 1Gbit/s zum Server zur Verfügung, doch der Datenverkehr mehrerer Clients kann auf die drei Verbindungen verteilt werden. Zudem besteht Redundanz bei Ausfall von bis zu zwei Verbindungen.
Zu beachten ist, dass auf Server und Switch der gleiche Loadbalancing Modus eingestellt wird, hier werden Quell- und Ziel-IP-Adresse als Kriterium herangezogen.
Der Server (Madmax) ist ein HP DL380G6 mit 4 Gigabit Ethernet Ports, auf NIC0 läuft das Management des ESXI Servers, auf NIC 1-3 der Portchannel 2. Es werden zwei VLANs zugelassen 100 und 101.

Konfigurationsbeispiel für einen Cisco Catalyst 3750G

Switch#
!
port-channel load-balance src-dst-ip
!
interface Port-channel 2
description *** Madmax Link Aggregation ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101
switchport mode trunk
switchport nonegotiate
!
!
interface GigabitEthernet1/0/9
description *** Madmax nic0 Management Interface für ESXI  ***
switchport access vlan 100
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address sticky xxxx.xxxx.xxxx vlan access
load-interval 30
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/10
description *** Madmax nic1 LAGG ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet1/0/11
description *** Madmax nic2 LAGG ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet1/0/12
description *** Madmax nicx LAGG ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101
switchport mode trunk
switchport nonegotiate
channel-group 2 mode on
!

Switch#show etherchannel 2 summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator

M – not in use, minimum links not met
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 2
Number of aggregators: 2

Group Port-channel Protocol Ports
——+————-+———–+———————————————–
2 Po2(SU) – Gi1/0/10(P) Gi1/0/11(P) Gi1/0/12(P)

Switch#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address

Switch#

Die Einrichtung unter ESXI 6.5 ist eigentlich selbsterklärend:

die vier NICs im Server

1. virtuellen Switch erstellen

2. Switch bearbeiten und Interfaces hinzufügen

drei Uplinks auf NIC 1-3 und Lastausgleich anhand der IP Adressen

3. Portgruppe(n) hinzufügen, VLAN Tags setzen. Eventuell auf Portchannel im Switch noch das VLAN freigeben mit „switchport trunk allowed vlan add xxx“

zusätzliche Portgruppe einrichten für VLAN 102

Kommentar verfassen